Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "The LLVM Compiler Infrastructure" |
| 5 | HOMEPAGE = "http://llvm.org" |
| 6 | LICENSE = "NCSA" |
| 7 | SECTION = "devel" |
| 8 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=c6b766a4e85dd28301eeed54a6684648" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 11 | DEPENDS = "libffi libxml2 zlib libedit ninja-native llvm-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | |
| 13 | RDEPENDS_${PN}_append_class-target = " ncurses-terminfo" |
| 14 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | inherit cmake pkgconfig |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | |
| 17 | PROVIDES += "llvm${PV}" |
| 18 | |
| 19 | LLVM_RELEASE = "${PV}" |
| 20 | LLVM_DIR = "llvm${LLVM_RELEASE}" |
| 21 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 22 | SRCREV = "19a71f6bdf2dddb10764939e7f0ec2b98dba76c9" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | |
| 24 | BRANCH = "release/${MAJOR_VERSION}.x" |
| 25 | MAJOR_VERSION = "8" |
| 26 | MINOR_VERSION = "0" |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 27 | PATCH_VERSION = "1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | SOLIBVER = "1" |
| 29 | PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}" |
| 30 | SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 31 | file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \ |
| 32 | file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 34 | |
| 35 | S = "${WORKDIR}/git/llvm" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 36 | |
| 37 | LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 39 | def get_llvm_arch(bb, d, arch_var): |
| 40 | import re |
| 41 | a = d.getVar(arch_var) |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 42 | if re.match(r'(i.86|athlon|x86.64)$', a): return 'X86' |
| 43 | elif re.match(r'arm$', a): return 'ARM' |
| 44 | elif re.match(r'armeb$', a): return 'ARM' |
| 45 | elif re.match(r'aarch64$', a): return 'AArch64' |
| 46 | elif re.match(r'aarch64_be$', a): return 'AArch64' |
| 47 | elif re.match(r'mips(isa|)(32|64|)(r6|)(el|)$', a): return 'Mips' |
| 48 | elif re.match(r'p(pc|owerpc)(|64)', a): return 'PowerPC' |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 49 | else: |
| 50 | raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a) |
| 51 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 52 | def get_llvm_host_arch(bb, d): |
| 53 | return get_llvm_arch(bb, d, 'HOST_ARCH') |
| 54 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 55 | # |
| 56 | # Default to build all OE-Core supported target arches (user overridable). |
| 57 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 58 | LLVM_TARGETS ?= "AMDGPU;${@get_llvm_host_arch(bb, d)}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 59 | |
| 60 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 61 | ARM_INSTRUCTION_SET_armv4t = "arm" |
| 62 | |
| 63 | EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \ |
| 64 | -DLLVM_ENABLE_EXPENSIVE_CHECKS=OFF \ |
| 65 | -DLLVM_ENABLE_PIC=ON \ |
| 66 | -DLLVM_BINDINGS_LIST='' \ |
| 67 | -DLLVM_LINK_LLVM_DYLIB=ON \ |
| 68 | -DLLVM_ENABLE_FFI=ON \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 69 | -DLLVM_ENABLE_RTTI=ON \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 70 | -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \ |
| 71 | -DLLVM_OPTIMIZED_TABLEGEN=ON \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 72 | -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 73 | -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 74 | -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 75 | -G Ninja" |
| 76 | |
| 77 | EXTRA_OECMAKE_append_class-target = "\ |
| 78 | -DCMAKE_CROSSCOMPILING:BOOL=ON \ |
| 79 | -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 80 | -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 81 | " |
| 82 | |
| 83 | EXTRA_OECMAKE_append_class-nativesdk = "\ |
| 84 | -DCMAKE_CROSSCOMPILING:BOOL=ON \ |
| 85 | -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 86 | -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 87 | " |
| 88 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 89 | CXXFLAGS_append_class-target_powerpc = " -mlongcall" |
| 90 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 91 | do_configure_prepend() { |
| 92 | # Fix paths in llvm-config |
| 93 | sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp |
| 94 | sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp |
| 95 | sed -ri "s#lib/${LLVM_DIR}#${baselib}/${LLVM_DIR}#g" ${S}/tools/llvm-config/llvm-config.cpp |
| 96 | } |
| 97 | |
| 98 | do_compile() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 99 | ninja -v ${PARALLEL_MAKE} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 100 | } |
| 101 | |
| 102 | do_compile_class-native() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 103 | ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 104 | } |
| 105 | |
| 106 | do_install() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 107 | DESTDIR=${LLVM_INSTALL_DIR} ninja -v install |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 108 | install -D -m 0755 ${B}/bin/llvm-config ${D}${libdir}/${LLVM_DIR}/llvm-config |
| 109 | |
| 110 | install -d ${D}${bindir}/${LLVM_DIR} |
| 111 | cp -r ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/ |
| 112 | |
| 113 | install -d ${D}${includedir}/${LLVM_DIR} |
| 114 | cp -r ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/ |
| 115 | |
| 116 | install -d ${D}${libdir}/${LLVM_DIR} |
| 117 | |
| 118 | # The LLVM sources have "/lib" embedded and so we cannot completely rely on the ${libdir} variable |
| 119 | if [ -d ${LLVM_INSTALL_DIR}${libdir}/ ]; then |
| 120 | cp -r ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/ |
| 121 | elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib ]; then |
| 122 | cp -r ${LLVM_INSTALL_DIR}${prefix}/lib/* ${D}${libdir}/${LLVM_DIR}/ |
| 123 | elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib64 ]; then |
| 124 | cp -r ${LLVM_INSTALL_DIR}${prefix}/lib64/* ${D}${libdir}/${LLVM_DIR}/ |
| 125 | fi |
| 126 | |
| 127 | # Remove unnecessary cmake files |
| 128 | rm -rf ${D}${libdir}/${LLVM_DIR}/cmake |
| 129 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 130 | ln -s ${LLVM_DIR}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV} ${D}${libdir}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 131 | |
| 132 | # We'll have to delete the libLLVM.so due to multiple reasons... |
| 133 | rm -rf ${D}${libdir}/${LLVM_DIR}/libLLVM.so |
| 134 | rm -rf ${D}${libdir}/${LLVM_DIR}/libLTO.so |
| 135 | } |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 136 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 137 | do_install_class-native() { |
| 138 | install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV} |
| 139 | install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 140 | install -D -m 0755 ${B}/lib/libLLVM-${MAJOR_VERSION}.so ${D}${libdir}/libLLVM-${MAJOR_VERSION}.so |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 141 | } |
| 142 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 143 | PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 144 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 145 | RRECOMMENDS_${PN}-dev += "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-liboptremarks" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 146 | |
| 147 | FILES_${PN}-bugpointpasses = "\ |
| 148 | ${libdir}/${LLVM_DIR}/BugpointPasses.so \ |
| 149 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 150 | |
| 151 | FILES_${PN}-libllvm = "\ |
| 152 | ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.so \ |
| 153 | ${libdir}/libLLVM-${MAJOR_VERSION}.so \ |
| 154 | " |
| 155 | |
| 156 | FILES_${PN}-liblto += "\ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 157 | ${libdir}/${LLVM_DIR}/libLTO.so.* \ |
| 158 | " |
| 159 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 160 | FILES_${PN}-liboptremarks += "\ |
| 161 | ${libdir}/${LLVM_DIR}/libOptRemarks.so.* \ |
| 162 | " |
| 163 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 164 | FILES_${PN}-llvmhello = "\ |
| 165 | ${libdir}/${LLVM_DIR}/LLVMHello.so \ |
| 166 | " |
| 167 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 168 | FILES_${PN}-dev += " \ |
| 169 | ${libdir}/${LLVM_DIR}/llvm-config \ |
| 170 | ${libdir}/${LLVM_DIR}/libOptRemarks.so \ |
| 171 | ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}.so \ |
| 172 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 173 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 174 | FILES_${PN}-staticdev += "\ |
| 175 | ${libdir}/${LLVM_DIR}/*.a \ |
| 176 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 177 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 178 | INSANE_SKIP_${PN}-libllvm += "dev-so" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 179 | |
| 180 | BBCLASSEXTEND = "native nativesdk" |