Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 6 | inherit gnomebase bash-completion gettext upstream-version-is-even |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 8 | DEPENDS += "libsecret glib-2.0 glib-2.0-native gconf libgudev shadow-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
| 11 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 12 | SRC_URI[archive.md5sum] = "47db9bec616e089513b7f1386e5c7d5f" |
| 13 | SRC_URI[archive.sha256sum] = "bdefe8fec6a1097f0c126fa2a4533667c98a86e237ac640518000e16b363971e" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
| 15 | |
| 16 | EXTRA_OEMESON = " \ |
| 17 | -Dbluray=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | -Dgoa=false \ |
| 19 | -Dgoogle=false \ |
| 20 | -Dnfs=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 24 | |
| 25 | FILES_${PN} += " \ |
| 26 | ${datadir}/glib-2.0 \ |
| 27 | ${datadir}/GConf \ |
| 28 | ${datadir}/dbus-1/services \ |
| 29 | ${libdir}/gio/modules/*.so \ |
| 30 | ${libdir}/tmpfiles.d \ |
| 31 | ${systemd_user_unitdir} \ |
| 32 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | |
| 34 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 35 | FILES_${PN}-dev += "${libdir}/gio/modules/*.la" |
| 36 | |
| 37 | FILES_gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 38 | FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 39 | FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
| 40 | |
| 41 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" |
| 42 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 43 | PACKAGECONFIG ?= "libgphoto2 \ |
| 44 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 45 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','udisks2','',d)} \ |
| 46 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','admin','',d)} \ |
| 47 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 48 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 49 | PACKAGECONFIG[udisks2] = "-Dudisks2=true, -Dudisks2=false, udisks2, udisks2" |
| 50 | PACKAGECONFIG[admin] = "-Dadmin=true, -Dadmin=false, libcap polkit" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | PACKAGECONFIG[afc] = "-Dafc=true, -Dafc=false, libimobiledevice libplist" |
| 52 | PACKAGECONFIG[archive] = "-Darchive=true, -Darchive=false, libarchive" |
| 53 | PACKAGECONFIG[dnssd] = "-Ddnssd=true, -Ddnssd=false, avahi" |
| 54 | PACKAGECONFIG[gcr] = "-Dgcr=true, -Dgcr=false, gcr" |
| 55 | PACKAGECONFIG[http] = "-Dhttp=true, -Dhttp=false, libsoup-2.4" |
| 56 | PACKAGECONFIG[libmtp] = "-Dmtp=true, -Dmtp=false, libmtp" |
| 57 | PACKAGECONFIG[logind] = "-Dlogind=true, -Dlogind=false, systemd" |
| 58 | PACKAGECONFIG[libgphoto2] = "-Dgphoto2=true, -Dgphoto2=false, libgphoto2" |
| 59 | PACKAGECONFIG[samba] = "-Dsmb=true, -Dsmb=false, samba" |
| 60 | PACKAGECONFIG[systemd] = "-Dsystemduserunitdir=${systemd_user_unitdir} -Dtmpfilesdir=${libdir}/tmpfiles.d, -Dsystemduserunitdir=no -Dtmpfilesdir=no, systemd" |
| 61 | |
| 62 | # needs meta-filesystems |
| 63 | PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse" |
| 64 | |
| 65 | # libcdio-paranoia recipe doesn't exist yet |
| 66 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
| 67 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 68 | do_install_append() { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 69 | if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then |
| 70 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
| 71 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 72 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
| 73 | fi |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 74 | |
| 75 | # After rebuilds (not from scracth) it can happen that the executables in |
| 76 | # libexec ar missing executable permission flag. Not sure but it came up |
| 77 | # during transition to meson. Looked into build files and logs but could |
| 78 | # not find suspicious |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 79 | for exe in `find ${D}/${libexecdir}`; do |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 80 | chmod +x $exe |
| 81 | done |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 82 | } |