Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 1 | SUMMARY = "open-source formatting library for C++" |
| 2 | DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams." |
| 3 | HOMEPAGE = "https://fmt.dev" |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c2e38bc8629eac247a73b65c1548b2f0" |
| 6 | SRCREV = "9e554999ce02cf86fcdfe74fe740c4fe3f5a56d5" |
| 7 | PV .= "+git${SRCPV}" |
| 8 | |
| 9 | SRC_URI += "git://github.com/fmtlib/fmt" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | inherit ptest |
| 15 | |
| 16 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" |