Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Satyr is a collection of low-level algorithms for program \ |
| 2 | failure processing, analysis, and reporting supporting kernel space, user \ |
| 3 | space, Python, and Java programs" |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/abrt/satyr" |
| 6 | LICENSE = "GPLv2" |
| 7 | |
| 8 | inherit autotools-brokensep python3native pkgconfig |
| 9 | |
| 10 | SRC_URI = "git://github.com/abrt/satyr.git \ |
| 11 | file://0002-fix-compile-failure-against-musl-C-library.patch \ |
| 12 | " |
| 13 | SRCREV = "dff1b877d42bf2153f8f090905d9cc8fb333bf1e" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 17 | |
| 18 | DEPENDS += " \ |
| 19 | gdb \ |
| 20 | " |
| 21 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 22 | PACKAGES += "python3-${BPN}" |
| 23 | FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | PACKAGECONFIG ??= "python3 rpm" |
| 26 | PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2" |
| 27 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
| 28 | PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm" |
| 29 | |
| 30 | do_configure_prepend() { |
| 31 | ${S}/gen-version |
| 32 | } |