Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. " |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08" |
| 4 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 5 | DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | SRC_URI = " \ |
| 8 | http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| 9 | file://0001-linux-lower-severity-of-unhandled-action-messages.patch \ |
| 10 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | SRC_URI[md5sum] = "236bb439d9ff1151450b3d8582399532" |
| 12 | SRC_URI[sha256sum] = "24bcc2f6ab25a2533bac70b587bcb019e591293076920f5b5e04bdedc140a401" |
| 13 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | inherit autotools pkgconfig gettext gobject-introspection systemd distro_features_check |
| 15 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 17 | PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist" |
| 18 | PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \ |
| 19 | --without-systemdutildir --without-systemdsystemunitdir,systemd" |
| 20 | |
| 21 | EXTRA_OECONF = " --with-backend=linux" |
| 22 | |
| 23 | SYSTEMD_SERVICE_${PN} = "upower.service" |
| 24 | # don't start on boot by default - dbus does that on demand |
| 25 | SYSTEMD_AUTO_ENABLE = "disable" |
| 26 | |
| 27 | do_configure_prepend() { |
| 28 | sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am |
| 29 | sed -i -e 's: doc : :g' ${S}/Makefile.am |
| 30 | } |
| 31 | |
| 32 | RDEPENDS_${PN} += "dbus" |
| 33 | RRECOMMENDS_${PN} += "pm-utils" |
| 34 | FILES_${PN} += "${datadir}/dbus-1/ \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | ${base_libdir}/udev/* \ |
| 36 | " |