Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | DESCRIPTION = "Security packagegroup for Poky" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \ |
| 4 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 5 | |
| 6 | inherit packagegroup |
| 7 | |
| 8 | PACKAGES = "\ |
| 9 | packagegroup-core-security \ |
| 10 | packagegroup-security-utils \ |
| 11 | packagegroup-security-scanners \ |
| 12 | packagegroup-security-ids \ |
| 13 | packagegroup-security-mac \ |
| 14 | ${@bb.utils.contains("MACHINE_FEATURES", "tpm", "packagegroup-security-tpm", "",d)} \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS_packagegroup-core-security = "\ |
| 18 | packagegroup-security-utils \ |
| 19 | packagegroup-security-scanners \ |
| 20 | packagegroup-security-ids \ |
| 21 | packagegroup-security-mac \ |
| 22 | ${@bb.utils.contains("MACHINE_FEATURES", "tpm", "packagegroup-security-tpm", "",d)} \ |
| 23 | " |
| 24 | |
| 25 | SUMMARY_packagegroup-security-utils = "Security utilities" |
| 26 | RDEPENDS_packagegroup-security-utils = "\ |
| 27 | checksec \ |
| 28 | nmap \ |
| 29 | pinentry \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | python-scapy \ |
| 31 | ding-libs \ |
| 32 | xmlsec1 \ |
| 33 | keyutils \ |
| 34 | libseccomp \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 35 | ${@bb.utils.contains("DISTRO_FEATURES", "pam", "sssd", "",d)} \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 36 | ${@bb.utils.contains("DISTRO_FEATURES", "pax", "pax-utils", "",d)} \ |
| 37 | " |
| 38 | |
| 39 | SUMMARY_packagegroup-security-scanners = "Security scanners" |
| 40 | RDEPENDS_packagegroup-security-scanners = "\ |
| 41 | nikto \ |
| 42 | checksecurity \ |
| 43 | clamav \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 44 | clamav-freshclam \ |
| 45 | clamav-cvd \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 46 | " |
| 47 | |
| 48 | SUMMARY_packagegroup-security-audit = "Security Audit tools " |
| 49 | RDEPENDS_packagegroup-security-audit = " \ |
| 50 | buck-security \ |
| 51 | redhat-security \ |
| 52 | " |
| 53 | |
| 54 | SUMMARY_packagegroup-security-hardening = "Security Hardening tools" |
| 55 | RDEPENDS_packagegroup-security-hardening = " \ |
| 56 | bastille \ |
| 57 | " |
| 58 | |
| 59 | SUMMARY_packagegroup-security-ids = "Security Intrusion Detection systems" |
| 60 | RDEPENDS_packagegroup-security-ids = " \ |
| 61 | tripwire \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 62 | samhain-standalone \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 63 | suricata \ |
| 64 | " |
| 65 | |
| 66 | SUMMARY_packagegroup-security-mac = "Security Mandatory Access Control systems" |
| 67 | RDEPENDS_packagegroup-security-mac = " \ |
| 68 | ${@bb.utils.contains("DISTRO_FEATURES", "tomoyo", "ccs-tools", "",d)} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 69 | ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "apparmor", "",d)} \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 70 | ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack", "",d)} \ |
| 71 | " |