James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=441793d25a658d58d79a1f87516a6ad1" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 6 | |
Andrew Geissler | dce5cf9 | 2020-05-17 11:54:15 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \ |
Andrew Geissler | dce5cf9 | 2020-05-17 11:54:15 -0500 | [diff] [blame] | 8 | " |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 9 | |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 10 | SRCREV = "626e7d61e44dee32887126c8f437dd077dec09cf" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit cmake |
| 15 | |
| 16 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 17 | |
| 18 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
| 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN}-dev = "" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 23 | |
| 24 | # other packages commonly reference the file directly as "json.hpp" |
| 25 | # create symlink to allow this usage |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | do_install:append() { |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 27 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 28 | } |