Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "JSON Web Token implementation in Python" |
| 2 | DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\ |
| 3 | Original implementation was written by https://github.com/progrium" |
| 4 | HOMEPAGE = "http://github.com/jpadilla/pyjwt" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c" |
| 7 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "fba44e7898bbca160a2b2b501f492824fc8382485d3a6f11ba5d0c1937ce6130" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | PYPI_PACKAGE = "PyJWT" |
| 11 | inherit pypi setuptools3 |
| 12 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} = "${PYTHON_PN}-cryptography" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |