Brad Bishop | 072e238 | 2019-09-25 08:16:16 -0400 | [diff] [blame] | 1 | SUMMARY = "Generator is a helper for generating test methods for nose while still using unittest." |
| 2 | DESCRIPTION = "Python package with modified subclasses of all stdlib XML \ |
| 3 | parsers that prevent any potentially malicious operation." |
| 4 | |
| 5 | LICENSE = "ISC" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00" |
| 7 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 8 | SRC_URI += " \ |
| 9 | file://run-ptest \ |
| 10 | " |
| 11 | |
Brad Bishop | 072e238 | 2019-09-25 08:16:16 -0400 | [diff] [blame] | 12 | SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1" |
| 13 | SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a" |
| 14 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 15 | inherit pypi setuptools3 ptest |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 18 | ${PYTHON_PN}-pytest \ |
| 19 | ${PYTHON_PN}-mock \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/tests |
| 24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 25 | } |
Brad Bishop | 072e238 | 2019-09-25 08:16:16 -0400 | [diff] [blame] | 26 | |
| 27 | DEPENDS += "python3-nose-native" |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | RDEPENDS:${PN} += "python3-six" |