Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 1 | require go-${PV}.inc |
2 | require go-target.inc | ||||
3 | |||||
4 | inherit linuxloader | ||||
5 | |||||
6 | export GOBUILDMODE="" | ||||
7 | export CGO_ENABLED_riscv64 = "" | ||||
8 | export GO_LDSO = "${@get_linuxloader(d)}" | ||||
9 | |||||
10 | # mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its | ||||
11 | # variants. | ||||
12 | python() { | ||||
13 | if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True): | ||||
14 | d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel") | ||||
15 | } |