Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Additional utilities for the opkg package manager" |
| 2 | SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://code.google.com/p/opkg/" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 8 | PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
| 10 | SRCREV = "53274f087565fd45d8452c5367997ba6a682a37a" |
| 11 | PV = "0.1.8+git${SRCPV}" |
| 12 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | SRC_URI = "git://git.yoctoproject.org/opkg-utils \ |
| 14 | file://opkg-build-Exit-when-fail-to-list-files.patch \ |
| 15 | file://0001-opkg-build-re-do-find-ls-code-to-not-fail-on-filenam.patch" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | SRC_URI_append_class-native = " file://tar_ignore_error.patch" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 21 | |
| 22 | PYTHONRDEPS = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold" |
| 23 | PYTHONRDEPS_class-native = "" |
| 24 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 25 | PACKAGECONFIG = "python update-alternatives" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[update-alternatives] = ",,," |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
| 29 | do_install() { |
| 30 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 31 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then |
| 32 | rm -f "${D}${bindir}/update-alternatives" |
| 33 | fi |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | } |
| 35 | |
| 36 | do_install_append_class-target() { |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 37 | if [ -e "${D}${bindir}/update-alternatives" ]; then |
| 38 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g' |
| 39 | fi |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 40 | } |
| 41 | |
| 42 | PACKAGES =+ "update-alternatives-opkg" |
| 43 | FILES_update-alternatives-opkg = "${bindir}/update-alternatives" |
| 44 | RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth" |
| 45 | RREPLACES_update-alternatives-opkg = "update-alternatives-cworth" |
| 46 | RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" |
| 47 | |
| 48 | BBCLASSEXTEND = "native nativesdk" |