Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Error - Error/exception handling in an OO-ish way" |
| 2 | DESCRIPTION = "The Error package provides two interfaces. Firstly \ |
| 3 | Error provides a procedural interface to exception handling. \ |
| 4 | Secondly Error is a base class for errors/exceptions that can \ |
| 5 | either be thrown, for subsequent catch, or can simply be recorded." |
| 6 | |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100" |
| 11 | |
| 12 | DEPENDS += "perl" |
| 13 | |
| 14 | SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "7e3676a7fb14f65f568f12d4b40a2a72" |
| 17 | SRC_URI[sha256sum] = "074db7c783a67b0667eca64a4f6a0c3de94998afc92c01d6453163eb04b9150d" |
| 18 | |
| 19 | S = "${WORKDIR}/Error-${PV}" |
| 20 | |
| 21 | inherit cpan |
| 22 | |
| 23 | do_compile() { |
| 24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 25 | cpan_do_compile |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |