Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 2 | |
| 3 | # Applications using this library needs to add link against libbreakpad_client.a. |
| 4 | |
| 5 | SUMMARY = "An open-source multi-platform crash reporting system" |
| 6 | DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. " |
| 7 | HOMEPAGE = "https://code.google.com/p/google-breakpad/" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=56c24a43c81c3af6fcf590851931489e" |
| 10 | SECTION = "libs" |
| 11 | |
| 12 | inherit autotools |
| 13 | |
| 14 | BBCLASSEXTEND = "native" |
| 15 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | PE = "2" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | PV = "1.0" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | SRCREV_FORMAT = "breakpad_gtest_protobuf_lss_gyp" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 22 | SRCREV_breakpad = "0c0e24f709288a129d665ec27d6f089189318385" |
| 23 | #v1.10.0 |
| 24 | SRCREV_gtest = "5ec7f0c4a113e2f18ac2c6cc7df51ad6afc24081" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 26 | SRCREV_lss = "8048ece6c16c91acfe0d36d1d3cc0890ab6e945c" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | SRCREV_gyp = "324dd166b7c0b39d513026fa52d6280ac6d56770" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | |
| 29 | SRC_URI = "git://github.com/google/breakpad;name=breakpad \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest \ |
| 31 | git://github.com/google/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf \ |
| 32 | git://chromium.googlesource.com/linux-syscall-support;protocol=https;destsuffix=git/src/third_party/lss;name=lss \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | git://chromium.googlesource.com/external/gyp;protocol=https;destsuffix=git/src/tools/gyp;name=gyp \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 34 | file://0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | file://0003-Fix-conflict-between-musl-libc-dirent.h-and-lss.patch \ |
| 36 | file://0001-Turn-off-sign-compare-for-musl-libc.patch \ |
| 37 | file://0002-sys-signal.h-is-a-nonportable-alias-for-signal.h.patch \ |
| 38 | file://0003-Dont-include-stab.h.patch \ |
| 39 | file://0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | file://0002-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch \ |
| 41 | file://mcontext.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | file://0001-disable-calls-to-getcontext-with-musl.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 43 | file://0001-lss-Match-syscalls-to-match-musl.patch;patchdir=src/third_party/lss \ |
| 44 | file://mips_asm_sgidefs.patch;patchdir=src/third_party/lss \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 45 | file://0001-Do-not-add-stack-pointer-to-clobber-list.patch;patchdir=src/third_party/lss \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 46 | " |
| 47 | S = "${WORKDIR}/git" |
| 48 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 49 | CXXFLAGS += "-D_GNU_SOURCE" |
| 50 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | COMPATIBLE_HOST_powerpc = "null" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | COMPATIBLE_HOST_riscv64 = "null" |
| 53 | COMPATIBLE_HOST_riscv32 = "null" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 54 | |
| 55 | do_install_append() { |
| 56 | install -d ${D}${includedir} |
| 57 | install -d ${D}${includedir}/breakpad |
| 58 | |
| 59 | install -d ${D}${includedir}/breakpad/client/linux/crash_generation |
| 60 | install -m 0644 ${S}/src/client/linux/crash_generation/crash_generation_client.h ${D}${includedir}/breakpad/client/linux/crash_generation/crash_generation_client.h |
| 61 | |
| 62 | install -d ${D}${includedir}/breakpad/client/linux/handler/ |
| 63 | install -m 0644 ${S}/src/client/linux/handler/exception_handler.h ${D}${includedir}/breakpad/client/linux/handler/exception_handler.h |
| 64 | install -m 0644 ${S}/src/client/linux/handler/minidump_descriptor.h ${D}${includedir}/breakpad/client/linux/handler/minidump_descriptor.h |
| 65 | |
| 66 | install -d ${D}${includedir}/breakpad/client/linux/dump_writer_common |
| 67 | install -m 0644 ${S}/src/client/linux/dump_writer_common/mapping_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/mapping_info.h |
| 68 | install -m 0644 ${S}/src/client/linux/dump_writer_common/thread_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/thread_info.h |
| 69 | install -m 0644 ${S}/src/client/linux/dump_writer_common/raw_context_cpu.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/raw_context_cpu.h |
| 70 | |
| 71 | install -d ${D}${includedir}/breakpad/client/linux/minidump_writer |
| 72 | install -m 0644 ${S}/src/client/linux/minidump_writer/linux_dumper.h ${D}${includedir}/breakpad/client/linux/minidump_writer/linux_dumper.h |
| 73 | install -m 0644 ${S}/src/client/linux/minidump_writer/minidump_writer.h ${D}${includedir}/breakpad/client/linux/minidump_writer/minidump_writer.h |
| 74 | |
| 75 | install -d ${D}${includedir}/breakpad/common |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 76 | install -m 0644 ${S}/src/common/memory_allocator.h ${D}${includedir}/breakpad/common/memory_allocator.h |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 77 | install -m 0644 ${S}/src/common/scoped_ptr.h ${D}${includedir}/breakpad/common/scoped_ptr.h |
| 78 | install -m 0644 ${S}/src/common/using_std_string.h ${D}${includedir}/breakpad/common/using_std_string.h |
| 79 | |
| 80 | install -d ${D}${includedir}/breakpad/google_breakpad/common |
| 81 | install -m 0644 ${S}/src/google_breakpad/common/breakpad_types.h ${D}${includedir}/breakpad/google_breakpad/common/breakpad_types.h |
| 82 | install -m 0644 ${S}/src/google_breakpad/common/minidump_format.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_format.h |
| 83 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_amd64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_amd64.h |
| 84 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm.h |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 85 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm64.h |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 86 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_mips.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_mips.h |
| 87 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc64.h |
| 88 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc.h |
| 89 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_sparc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_sparc.h |
| 90 | install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_x86.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_x86.h |
| 91 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_linux.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_linux.h |
| 92 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_mac.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_mac.h |
| 93 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_ps3.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_ps3.h |
| 94 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_solaris.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_solaris.h |
| 95 | install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_win32.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_win32.h |
| 96 | |
| 97 | install -d ${D}${includedir}/breakpad/third_party/lss |
| 98 | install -m 0644 ${S}/src/third_party/lss/linux_syscall_support.h ${D}${includedir}/breakpad/third_party/lss/linux_syscall_support.h |
| 99 | } |
| 100 | |
| 101 | PACKAGES =+ "${PN}-minidump-upload ${PN}-sym-upload" |
| 102 | |
| 103 | FILES_${PN}-minidump-upload = "${bindir}/minidump_upload" |
| 104 | FILES_${PN}-sym-upload = "${bindir}/sym_upload" |
| 105 | |
| 106 | |
| 107 | SYSROOT_PREPROCESS_FUNCS += "breakpad_populate_sysroot" |
| 108 | breakpad_populate_sysroot() { |
| 109 | sysroot_stage_dir ${D}/usr/include ${SYSROOT_DESTDIR}/usr/include |
| 110 | sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib |
| 111 | sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib |
| 112 | } |
| 113 | |
| 114 | # Fails to build with thumb-1 (qemuarm) |
| 115 | #| {standard input}: Assembler messages: |
| 116 | #| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne' |
| 117 | #| {standard input}:2179: Error: Thumb does not support conditional execution |
| 118 | #| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq' |
| 119 | #| {standard input}:2181: Error: Thumb does not support conditional execution |
| 120 | #| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!' |
| 121 | #| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!' |
| 122 | #| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]' |
| 123 | #| make: *** [src/client/linux/handler/exception_handler.o] Error 1 |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 124 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 125 | ARM_INSTRUCTION_SET_armv4 = "arm" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 126 | |
| 127 | TOOLCHAIN = "gcc" |