Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenGL function pointer management library" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 2 | DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \ |
| 3 | glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \ |
| 4 | very little knowledge needed on their part. They get to read GL specs and \ |
| 5 | write code using undecorated function names like glCompileShader()." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | HOMEPAGE = "https://github.com/anholt/libepoxy/" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b" |
| 11 | |
| 12 | SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \ |
| 13 | " |
| 14 | SRC_URI[md5sum] = "e2845de8d2782b2d31c01ae8d7cd4cbb" |
| 15 | SRC_URI[sha256sum] = "002958c5528321edd53440235d3c44e71b5b1e09b9177e8daf677450b6c4433d" |
| 16 | UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases" |
| 17 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 18 | inherit meson pkgconfig features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
| 20 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 21 | REQUIRED_DISTRO_FEATURES_class-native = "" |
| 22 | REQUIRED_DISTRO_FEATURES_class-nativesdk = "" |
| 23 | |
| 24 | PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl" |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 25 | PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl" |
| 27 | |
| 28 | EXTRA_OEMESON += "-Dtests=false" |
| 29 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 30 | PACKAGECONFIG_class-native = "egl x11" |
| 31 | PACKAGECONFIG_class-nativesdk = "egl x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |
| 34 | |
| 35 | # This will ensure that dlopen will attempt only GL libraries provided by host |
| 36 | do_install_append_class-native() { |
| 37 | chrpath --delete ${D}${libdir}/*.so |
| 38 | } |
| 39 | |
| 40 | do_install_append_class-nativesdk() { |
| 41 | chrpath --delete ${D}${libdir}/*.so |
| 42 | } |