Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Key/value database library with extensible hashing" |
| 2 | DESCRIPTION = "Library of database functions that use extensible hashing \ |
| 3 | and work similar to the standard UNIX dbm. These routines are provided \ |
| 4 | to a programmer needing to create and manipulate a hashed database." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/gdbm/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "GPL-3.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24" |
| 9 | |
| 10 | |
| 11 | SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \ |
| 12 | file://run-ptest \ |
| 13 | file://ptest.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[sha256sum] = "74b1081d21fff13ae4bd7c16e5d6e504a4c26f7cde1dca0d963a484174bbcacd" |
| 17 | |
| 18 | inherit autotools gettext texinfo lib_package ptest |
| 19 | |
| 20 | # Needed for dbm python module |
| 21 | EXTRA_OECONF = "--enable-libgdbm-compat --without-readline" |
| 22 | |
| 23 | # Stop presence of dbm/nbdm on the host contaminating builds |
| 24 | CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no" |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |
| 27 | |
| 28 | do_install:append () { |
| 29 | # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find |
| 30 | # these headers |
| 31 | install -d ${D}${includedir}/gdbm |
| 32 | ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h |
| 33 | ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h |
| 34 | } |
| 35 | |
| 36 | RDEPENDS:${PN}-ptest += "diffutils ${PN}-bin" |
| 37 | |
| 38 | do_compile_ptest() { |
| 39 | oe_runmake -C tests buildtests |
| 40 | } |
| 41 | |
| 42 | PACKAGES =+ "${PN}-compat \ |
| 43 | " |
| 44 | FILES:${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \ |
| 45 | " |