Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "The Mercurial distributed SCM" |
| 2 | HOMEPAGE = "http://mercurial.selenic.com/" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | DEPENDS = "python python-native" |
| 7 | DEPENDS_class-native = "python-native" |
| 8 | RDEPENDS_${PN} = "python python-modules" |
| 9 | |
| 10 | inherit python-dir |
| 11 | |
| 12 | SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz" |
| 13 | SRC_URI[md5sum] = "f9b2e4a3b5901ef744fa3abe4196e97e" |
| 14 | SRC_URI[sha256sum] = "89fa8ecbc8aa6e48e98f9803a1683ba91367124295dba2407b28c34ca621108d" |
| 15 | |
| 16 | S = "${WORKDIR}/mercurial-${PV}" |
| 17 | |
| 18 | BBCLASSEXTEND = "native" |
| 19 | |
| 20 | EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ |
| 21 | PREFIX=${prefix}" |
| 22 | |
| 23 | do_configure_append () { |
| 24 | sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile |
| 25 | } |
| 26 | |
| 27 | do_install () { |
| 28 | oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix} |
| 29 | } |
| 30 | |
| 31 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" |