Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'. |
| 2 | # The following is the difference between the old and the new license text. |
| 3 | # Please update the LICENSE value if needed, and summarize the changes in |
| 4 | # the commit message via 'License-Update:' tag. |
| 5 | # (example: 'License-Update: copyright years updated.') |
| 6 | # |
| 7 | # The changes: |
| 8 | # |
| 9 | # --- COPYING |
| 10 | # +++ COPYING |
| 11 | # @@ -293,7 +293,7 @@ |
| 12 | # <one line to give the program's name and a brief idea of what it does.> |
| 13 | # Copyright (C) <year> <name of author> |
| 14 | # |
| 15 | # - on, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USAThis program is free software; you can redistribute it and/or modify |
| 16 | # + This program is free software; you can redistribute it and/or modify |
| 17 | # it under the terms of the GNU General Public License as published by |
| 18 | # the Free Software Foundation; either version 2 of the License, or |
| 19 | # (at your option) any later version. |
| 20 | # |
| 21 | # |
| 22 | |
| 23 | require links.inc |
| 24 | |
| 25 | DEPENDS += "virtual/libx11" |
| 26 | RCONFLICTS_${PN} = "links" |
| 27 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 28 | inherit features_check |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | # depends on virtual/libx11 |
| 30 | REQUIRED_DISTRO_FEATURES = "x11" |
| 31 | |
| 32 | SRC_URI += " file://links2.desktop \ |
| 33 | http://www.xora.org.uk/oe/links2.png;name=icon" |
| 34 | |
| 35 | S = "${WORKDIR}/links-${PV}" |
| 36 | |
| 37 | EXTRA_OECONF = "--enable-graphics \ |
| 38 | --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \ |
| 39 | --without-libtiff --without-svgalib --without-fb \ |
| 40 | --without-directfb --without-pmshell --without-atheos \ |
| 41 | --with-x --without-gpm" |
| 42 | |
| 43 | do_install_append() { |
| 44 | install -d ${D}/${datadir}/applications |
| 45 | install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications |
| 46 | install -d ${D}/${datadir}/pixmaps |
| 47 | install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps |
| 48 | } |
| 49 | |
| 50 | SRC_URI[md5sum] = "645fb0c0294e4c3268f94d307d394ffb" |
| 51 | SRC_URI[sha256sum] = "82f03038d5e050a65681b9888762af41c40fd42dec7e59a8d630bfb0ee134a3f" |
| 52 | SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33" |
| 53 | SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47" |