blob: e25f8e6fb0baf3b27bcd0bcc1ca211786ad7092b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa"
7
8DEPENDS += "kea-native"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
12 file://0001-remove-AC_TRY_RUN.patch \
13 file://kea-dhcp4.service \
14 file://kea-dhcp6.service \
15 file://kea-dhcp-ddns.service \
16"
Andrew Geissler2ee498a2020-05-29 15:52:06 -050017SRC_URI[md5sum] = "4f8d1251fd41ef2e822a4eb3f0797d46"
18SRC_URI[sha256sum] = "0bba8b045672884a928ff4b2a8575ac5ba420eb6ba47a9338f1932bc38dcf866"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20inherit autotools systemd
21
22SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
23SYSTEMD_AUTO_ENABLE = "disable"
24
25DEBUG_OPTIMIZATION_remove_mips = " -Og"
26DEBUG_OPTIMIZATION_append_mips = " -O"
27BUILD_OPTIMIZATION_remove_mips = " -Og"
28BUILD_OPTIMIZATION_append_mips = " -O"
29
30DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
31DEBUG_OPTIMIZATION_append_mipsel = " -O"
32BUILD_OPTIMIZATION_remove_mipsel = " -Og"
33BUILD_OPTIMIZATION_append_mipsel = " -O"
34
35do_configure_prepend_class-target() {
36 mkdir -p ${B}/src/lib/log/compiler/
37 ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
38 # replace abs_top_builddir to avoid introducing the build path
39 # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
40 find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
41 sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in
42}
43
44do_install_append_class-target() {
45 install -d ${D}${systemd_system_unitdir}
46 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
47 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
48 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
49 ${D}${systemd_system_unitdir}/kea-dhcp*service
50}
51
52do_install_append() {
53 rm -rf "${D}${localstatedir}"
54}
55
56PACKAGECONFIG ??= "openssl log4cplus boost"
57
58PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl"
59PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus"
60PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost"
61
62FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
63FILES_${PN} += "${libdir}/hooks/*.so"
64
65BBCLASSEXTEND += "native"
66
67PARALLEL_MAKEINST = ""