Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ISC Kea DHCP Server" |
| 2 | DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS." |
| 3 | HOMEPAGE = "http://kea.isc.org" |
| 4 | SECTION = "connectivity" |
| 5 | LICENSE = "MPL-2.0 & Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa" |
| 7 | |
| 8 | DEPENDS += "kea-native" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ |
| 12 | file://0001-remove-AC_TRY_RUN.patch \ |
| 13 | file://kea-dhcp4.service \ |
| 14 | file://kea-dhcp6.service \ |
| 15 | file://kea-dhcp-ddns.service \ |
| 16 | " |
Andrew Geissler | 2ee498a | 2020-05-29 15:52:06 -0500 | [diff] [blame^] | 17 | SRC_URI[md5sum] = "4f8d1251fd41ef2e822a4eb3f0797d46" |
| 18 | SRC_URI[sha256sum] = "0bba8b045672884a928ff4b2a8575ac5ba420eb6ba47a9338f1932bc38dcf866" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | inherit autotools systemd |
| 21 | |
| 22 | SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" |
| 23 | SYSTEMD_AUTO_ENABLE = "disable" |
| 24 | |
| 25 | DEBUG_OPTIMIZATION_remove_mips = " -Og" |
| 26 | DEBUG_OPTIMIZATION_append_mips = " -O" |
| 27 | BUILD_OPTIMIZATION_remove_mips = " -Og" |
| 28 | BUILD_OPTIMIZATION_append_mips = " -O" |
| 29 | |
| 30 | DEBUG_OPTIMIZATION_remove_mipsel = " -Og" |
| 31 | DEBUG_OPTIMIZATION_append_mipsel = " -O" |
| 32 | BUILD_OPTIMIZATION_remove_mipsel = " -Og" |
| 33 | BUILD_OPTIMIZATION_append_mipsel = " -O" |
| 34 | |
| 35 | do_configure_prepend_class-target() { |
| 36 | mkdir -p ${B}/src/lib/log/compiler/ |
| 37 | ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler |
| 38 | # replace abs_top_builddir to avoid introducing the build path |
| 39 | # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target |
| 40 | find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g" |
| 41 | sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in |
| 42 | } |
| 43 | |
| 44 | do_install_append_class-target() { |
| 45 | install -d ${D}${systemd_system_unitdir} |
| 46 | install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} |
| 47 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 48 | -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 49 | ${D}${systemd_system_unitdir}/kea-dhcp*service |
| 50 | } |
| 51 | |
| 52 | do_install_append() { |
| 53 | rm -rf "${D}${localstatedir}" |
| 54 | } |
| 55 | |
| 56 | PACKAGECONFIG ??= "openssl log4cplus boost" |
| 57 | |
| 58 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl" |
| 59 | PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus" |
| 60 | PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost" |
| 61 | |
| 62 | FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a" |
| 63 | FILES_${PN} += "${libdir}/hooks/*.so" |
| 64 | |
| 65 | BBCLASSEXTEND += "native" |
| 66 | |
| 67 | PARALLEL_MAKEINST = "" |