Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | DEPENDS = "libusb-compat libftdi" |
| 5 | RDEPENDS_${PN} = "libusb1" |
| 6 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 7 | SRC_URI = " \ |
| 8 | git://repo.or.cz/openocd.git;protocol=http;name=openocd \ |
| 9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ |
| 10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ |
| 11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 12 | file://0001-Do-not-include-syscrtl.h-with-glibc.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 15 | SRCREV_FORMAT = "openocd" |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 16 | SRCREV_openocd = "ded67990255cc1e63c77832ffd6e6bef9120873d" |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 17 | SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 18 | SRCREV_jimtcl = "dc4ba7770d580800634f90b67a24e077b4a26d98" |
Andrew Geissler | 2ee498a | 2020-05-29 15:52:06 -0500 | [diff] [blame^] | 19 | SRCREV_libjaylink = "3322dfa5e7aa56f5b12b7f2197e3e6b850b7b66e" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | |
| 21 | PV = "0.10+gitr${SRCPV}" |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit pkgconfig autotools-brokensep gettext |
| 25 | |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 26 | BBCLASSEXTEND += "native nativesdk" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 28 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror" |
| 29 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | do_configure() { |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 31 | ./bootstrap nosubmodule |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup |
| 33 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 34 | oe_runconf ${EXTRA_OECONF} |
| 35 | } |
| 36 | |
| 37 | do_install() { |
| 38 | oe_runmake DESTDIR=${D} install |
| 39 | if [ -e "${D}${infodir}" ]; then |
| 40 | rm -Rf ${D}${infodir} |
| 41 | fi |
| 42 | if [ -e "${D}${mandir}" ]; then |
| 43 | rm -Rf ${D}${mandir} |
| 44 | fi |
| 45 | if [ -e "${D}${bindir}/.debug" ]; then |
| 46 | rm -Rf ${D}${bindir}/.debug |
| 47 | fi |
| 48 | } |
| 49 | |
| 50 | FILES_${PN} = " \ |
| 51 | ${datadir}/openocd/* \ |
| 52 | ${bindir}/openocd \ |
| 53 | " |
| 54 | |
| 55 | PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 56 | PACKAGECONFIG[remote-bitbang] = "--enable-remote-bitbang,--disable-remote-bitbang" |
| 57 | PACKAGECONFIG ??= "sysfsgpio remote-bitbang" |