blob: f763067cf016cda6abf8c2e1f7adfd260849469a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "SDK for connecting to AWS IoT using Python."
2HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
3LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
4LICENSE_${PN}-examples = "Apache-2.0"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
7 file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
8"
9
10SRC_URI[md5sum] = "d05596f02774ea39517765c5dced874a"
11SRC_URI[sha256sum] = "bcd68cb7fdb044dbd5e5d3a02c311b25717c0376168e7c992982130f19c51b03"
12
13inherit pypi setuptools3
14
15PYPI_PACKAGE = "AWSIoTPythonSDK"
16
17do_install_append() {
18 install -d -m0755 ${D}${datadir}/${BPN}/examples
19 cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
20 # this requires the full blown AWS Python SDK
21 rm -r ${D}${datadir}/${BPN}/examples/basicPubSub
22}
23
24PACKAGES =+ "${PN}-examples"
25
26RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-crypt \
28 ${PYTHON_PN}-datetime \
29 ${PYTHON_PN}-io \
30 ${PYTHON_PN}-json \
31 ${PYTHON_PN}-logging \
32 ${PYTHON_PN}-math \
33 ${PYTHON_PN}-netclient \
34 ${PYTHON_PN}-numbers \
35 ${PYTHON_PN}-threading \
36"
37RDEPENDS_${PN}-examples += "${PN}"
38
39FILES_${PN}-examples = "${datadir}/${BPN}/examples"
40
41BBCLASSEXTEND = "native nativesdk"