Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # This recipe is adapted from one in meta-jupyter: |
| 2 | # https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-mpmath_0.19.bb |
| 3 | |
| 4 | SUMMARY = "Python library for arbitrary-precision floating-point arithmetic" |
| 5 | HOMEPAGE = "https://pypi.org/project/mpmath/" |
| 6 | LICENSE = "BSD" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=efe9feb00df0b763941f2b1bbac7c402" |
| 8 | |
| 9 | SRC_URI[md5sum] = "acb1cdddf38e16084628065b174ddbfe" |
| 10 | SRC_URI[sha256sum] = "fc17abe05fbab3382b61a123c398508183406fa132e0223874578e20946499f6" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS_${PN} += "python3-image" |
| 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |