Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library" |
| 2 | DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \ |
| 3 | in C and optimized for embedded and RTOS environments. It can \ |
| 4 | be up to 20 times smaller than OpenSSL while still supporting \ |
| 5 | a full TLS client and server, up to TLS 1.3" |
| 6 | HOMEPAGE = "https://www.wolfssl.com/products/wolfssl" |
| 7 | BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
| 12 | PROVIDES += "cyassl" |
| 13 | RPROVIDES_${PN} = "cyassl" |
| 14 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \ |
| 16 | file://0001-Make-ByteReverseWords-available-for-big-and-little-e.patch \ |
| 17 | " |
| 18 | SRCREV = "0fa5af9929ce2ee99e8789996a3048f41a99830e" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit autotools |
| 22 | |
| 23 | BBCLASSEXTEND += "native nativesdk" |