Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Framebuffer image and doc viewer tools" |
| 2 | DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \ |
| 3 | with the main focus being photos." |
| 4 | HOMEPAGE = "http://linux.bytesex.org/fbida/" |
| 5 | AUTHOR = "Gerd Hoffmann" |
| 6 | SECTION = "utils" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
| 10 | |
| 11 | DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif" |
| 12 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \ |
| 14 | file://0001-Avoid-using-host-path.patch \ |
| 15 | file://fix-preprocessor.patch \ |
| 16 | file://support-jpeg-turbo.patch \ |
| 17 | file://use-jpeg-turbo.patch \ |
| 18 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018" |
| 20 | SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6" |
| 21 | |
| 22 | B = "${WORKDIR}/build" |
| 23 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | inherit pkgconfig |
| 25 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile" |
| 27 | |
| 28 | PACKAGECONFIG ??= "gif png curl" |
| 29 | PACKAGECONFIG[curl] = ",,curl" |
| 30 | PACKAGECONFIG[gif] = ",,giflib" |
| 31 | PACKAGECONFIG[png] = ",,libpng" |
| 32 | PACKAGECONFIG[tiff] = ",,tiff" |
| 33 | PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif" |
| 34 | PACKAGECONFIG[webp] = ",,libwebp" |
| 35 | PACKAGECONFIG[lirc] = ",,lirc" |
| 36 | |
| 37 | do_compile() { |
| 38 | sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile |
| 39 | sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 40 | sed -i -e 's: cpp: ${CPP}:' ${S}/GNUmakefile |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 41 | |
| 42 | # Be sure to respect preferences (force to "no") |
| 43 | # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 44 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 46 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 47 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 48 | sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 49 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 50 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 51 | sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 52 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 53 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 54 | sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 55 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 56 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 57 | sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 58 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 59 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 60 | sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 61 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 62 | if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 63 | sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile |
| 64 | fi |
| 65 | |
| 66 | oe_runmake |
| 67 | } |
| 68 | |
| 69 | do_install() { |
| 70 | oe_runmake 'DESTDIR=${D}' install |
| 71 | } |
| 72 | |
| 73 | RDEPENDS_${PN} = "ttf-dejavu-sans-mono bash" |