Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Xfce4 settings" |
| 2 | SECTION = "x11/wm" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | DEPENDS = "exo exo-native garcon gtk+ libxfce4util libxfce4ui xfconf dbus-glib libxi virtual/libx11 xrandr libxcursor libxklavier upower" |
| 6 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 7 | inherit xfce xfce-git distro_features_check |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
| 11 | # schnitzeltony git repo is the mainline repo |
| 12 | # + datetime-setter - sent to mainline but strange response |
| 13 | # + minor bugfixes - sent mainline but no response |
| 14 | # + option to hide mousepointer for a specific (touch) input device - sent mainline but no response |
| 15 | SRC_URI = " \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | git://github.com/schnitzeltony/xfce4-settings.git;protocol=git;branch=for-oe-4.12.4 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | file://0001-xsettings.xml-Set-default-themes.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | file://0002-Fix-linking-to-dbus-glib-bug-13633.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | SRCREV = "75d7c9b15e5ccce12b0864d3659ae9b6de96e245" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | PV = "4.12.4+git${SRCPV}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | EXTRA_OECONF += "--enable-maintainer-mode --disable-debug" |
| 25 | |
| 26 | PACKAGECONFIG ??= " \ |
| 27 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \ |
| 28 | ${@bb.utils.contains('DISTRO_FEATURES','alsa','sound-setter', bb.utils.contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \ |
| 29 | " |
| 30 | PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata" |
| 31 | PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify" |
| 32 | PACKAGECONFIG[sound-setter] = "--enable-sound-settings, --disable-sound-settings, libcanberra, libcanberra-gtk2 sound-theme-freedesktop" |
| 33 | |
| 34 | FILES_${PN} += " \ |
| 35 | ${libdir}/xfce4 \ |
| 36 | ${datadir}/xfce4 \ |
| 37 | " |
| 38 | |
| 39 | RRECOMMENDS_${PN} += "adwaita-icon-theme" |
| 40 | RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}" |
| 41 | RRECOMMENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}" |