Yuan Yao | 72b8b7c | 2018-09-12 14:58:22 +0800 | [diff] [blame] | 1 | SUMMARY = "HXT Rep board wiring" |
| 2 | DESCRIPTION = "Board wiring information for the HXT Rep system." |
| 3 | PR = "r1" |
Patrick Venture | 3132272 | 2018-11-06 09:46:03 -0800 | [diff] [blame^] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${HXTBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Yuan Yao | 72b8b7c | 2018-09-12 14:58:22 +0800 | [diff] [blame] | 6 | |
| 7 | inherit allarch |
| 8 | inherit setuptools |
| 9 | inherit pythonnative |
Yuan Yao | 72b8b7c | 2018-09-12 14:58:22 +0800 | [diff] [blame] | 10 | |
| 11 | PROVIDES += "virtual/obmc-inventory-data" |
| 12 | RPROVIDES_${PN} += "virtual-obmc-inventory-data" |
| 13 | |
| 14 | DEPENDS += "python" |
| 15 | |
| 16 | S = "${WORKDIR}" |
| 17 | SRC_URI += "file://Stardragon4800-rep2.py" |
| 18 | |
| 19 | python() { |
| 20 | machine = d.getVar('MACHINE', True).capitalize() + '.py' |
| 21 | d.setVar('_config_in_skeleton', machine) |
| 22 | } |
| 23 | |
| 24 | do_make_setup() { |
| 25 | cp ${S}/${_config_in_skeleton} \ |
| 26 | ${S}/obmc_system_config.py |
| 27 | cat <<EOF > ${S}/setup.py |
| 28 | from distutils.core import setup |
| 29 | |
| 30 | setup(name='${BPN}', |
| 31 | version='${PR}', |
| 32 | py_modules=['obmc_system_config'], |
| 33 | ) |
| 34 | EOF |
| 35 | } |
| 36 | |
| 37 | addtask make_setup after do_patch before do_configure |
| 38 | |