Joel Stanley | 88aae3e | 2018-05-11 15:16:32 +0930 | [diff] [blame] | 1 | SUMMARY = "OpenPower Hostboot Boot settings tool" |
2 | PR = "r1" | ||||
3 | |||||
4 | inherit obmc-phosphor-license | ||||
5 | inherit obmc-phosphor-systemd | ||||
6 | inherit allarch | ||||
7 | |||||
8 | SRC_URI = "file://hb_settings" | ||||
9 | SYSTEMD_SERVICE_${PN} += "hostboot-settings.service" | ||||
10 | |||||
11 | do_fetch[noexec] = "1" | ||||
12 | do_patch[noexec] = "1" | ||||
13 | do_configure[noexec] = "1" | ||||
14 | do_compile[noexec] = "1" | ||||
15 | |||||
16 | do_install() { | ||||
17 | install -d ${D}${bindir} | ||||
18 | install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir} | ||||
19 | } |