Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenGL (ES) 2.0 benchmark" |
| 2 | DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. \ |
| 3 | It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0." |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/glmark2/glmark2" |
| 5 | BUGTRACKER = "https://github.com/glmark2/glmark2/issues" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
| 7 | LICENSE = "GPLv3+ & SGIv1" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 9 | file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552" |
| 10 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | DEPENDS = "libpng jpeg udev" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 12 | DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-native wayland-protocols', '', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 14 | PV = "2021.02+${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 16 | SRC_URI = " \ |
| 17 | git://github.com/glmark2/glmark2.git;protocol=https \ |
| 18 | file://0001-fix-dispmanx-build.patch \ |
| 19 | file://0002-run-dispmanx-fullscreen.patch \ |
| 20 | " |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 21 | SRCREV = "4b2bbe803576d48f08367aa5441740f9319c21e7" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 25 | inherit waf pkgconfig features_check |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 27 | ANY_OF_DISTRO_FEATURES = "opengl dispmanx" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 29 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gles2', '', d)} \ |
| 30 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gles2', '', d)} \ |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 31 | ${@bb.utils.contains('DISTRO_FEATURES', 'dispmanx', 'dispmanx', '', d)} \ |
| 32 | drm-gles2 \ |
| 33 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 34 | |
| 35 | PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11" |
| 36 | PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm virtual/libgbm" |
| 38 | PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm virtual/libgbm" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | PACKAGECONFIG[wayland-gl] = ",,virtual/libgl wayland" |
| 40 | PACKAGECONFIG[wayland-gles2] = ",,virtual/libgles2 wayland" |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 41 | PACKAGECONFIG[dispmanx] = ",,virtual/libgles2 virtual/libx11" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 42 | |
| 43 | python __anonymous() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 44 | packageconfig = (d.getVar("PACKAGECONFIG") or "").split() |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | flavors = [] |
| 46 | if "x11-gles2" in packageconfig: |
| 47 | flavors.append("x11-glesv2") |
| 48 | if "x11-gl" in packageconfig: |
| 49 | flavors.append("x11-gl") |
| 50 | if "wayland-gles2" in packageconfig: |
| 51 | flavors.append("wayland-glesv2") |
| 52 | if "wayland-gl" in packageconfig: |
| 53 | flavors.append("wayland-gl") |
| 54 | if "drm-gles2" in packageconfig: |
| 55 | flavors.append("drm-glesv2") |
| 56 | if "drm-gl" in packageconfig: |
| 57 | flavors.append("drm-gl") |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 58 | if "dispmanx" in packageconfig: |
| 59 | flavors = ["dispmanx-glesv2"] |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 60 | if flavors: |
| 61 | d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors)) |
| 62 | } |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 63 | |