Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Ceres Solver is an open source C++ library for modeling and solving large, complicated optimization problems." |
| 2 | AUTHOR = "Sameer Agarwal and Keir Mierle and Others" |
| 3 | HOMEPAGE = "http://ceres-solver.org/" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bb761279816b72be19d7ce646e4e2a14" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "libeigen glog" |
| 8 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | SRC_URI = "git://github.com/ceres-solver/ceres-solver.git" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 10 | SRCREV = "399cda773035d99eaf1f4a129a666b3c4df9d1b1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | inherit cmake |
| 15 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 16 | do_configure_prepend() { |
| 17 | # otherwise https://github.com/ceres-solver/ceres-solver/blob/0b748597889f460764f6c980a00c6f502caa3875/cmake/AddGerritCommitHook.cmake#L68 |
| 18 | # will try to fetch https://ceres-solver-review.googlesource.com/tools/hooks/commit-msg durind do_configure |
| 19 | # which sometimes gets stuck (as there is no TIMEOUT set in DOWNLOAD) |
| 20 | # and we really don't need Gerrit's Change-Id tags when just building this |
| 21 | touch ${S}/.git/hooks/commit-msg |
| 22 | } |
| 23 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 24 | # We don't want path to eigen3 in ceres-solver RSS to be |
| 25 | # used by components which use CeresConfig.cmake from their |
| 26 | # own RSS |
| 27 | # ceres-solver/1.14-r0/packages-split/ceres-solver-dev/usr/lib/cmake/Ceres/CeresConfig.cmake: set(Eigen3_DIR ceres-solver/1.14-r0/recipe-sysroot/usr/share/eigen3/cmake) |
| 28 | # ceres-solver/1.14-r0/packages-split/ceres-solver-dev/usr/lib/cmake/Ceres/CeresConfig.cmake: list(APPEND EIGEN_INCLUDE_DIR_HINTS ceres-solver/1.14-r0/recipe-sysroot/usr/include/eigen3) |
| 29 | # ceres-solver/1.14-r0/packages-split/ceres-solver-dev/usr/lib/cmake/Ceres/CeresConfig.cmake: set(glog_DIR ceres-solver/1.14-r0/recipe-sysroot/usr/lib/cmake/glog) |
| 30 | SSTATE_SCAN_FILES += "*.cmake" |
| 31 | |
| 32 | PACKAGECONFIG ??= "" |
| 33 | |
| 34 | # suitesparse* recipes will be in meta-ros layer |
| 35 | PACKAGECONFIG[suitesparse] = "-DSUITESPARSE=ON,-DSUITESPARSE=OFF,suitesparse-config suitesparse-amd suitesparse-camd suitesparse-colamd suitesparse-ccolamd suitesparse-cholmod suitesparse-metis suitesparse-spqr" |
| 36 | PACKAGECONFIG[cxsparse] = "-DCXSPARSE=ON,-DCXSPARSE=OFF,suitesparse-cxsparse" |
| 37 | PACKAGECONFIG[lapack] = "-DLAPACK=ON,-DLAPACK=OFF,lapack" |
| 38 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 39 | # Only a static library and headers are created |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | RDEPENDS_${PN}-dev = "" |
| 41 | RRECOMMENDS_${PN}-dev = "${PN}-staticdev" |
| 42 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |