Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ddf47d0ff1849bce3257ccbc1fd275c" |
| 4 | HOMEPAGE="https://github.com/holgern/py-scrypt" |
| 5 | |
| 6 | SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "25b5075f2238be93af1cd574540a5ea01b8547f9b678aa72d22fce22577475ec" |
| 9 | |
| 10 | inherit pypi ptest setuptools3 dos2unix |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS_${PN}-ptest += " \ |
| 17 | ${PYTHON_PN}-pytest \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |