Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "websocket client for python" |
| 2 | DESCRIPTION = "\ |
| 3 | websocket-client module is WebSocket client for python. \ |
| 4 | This provide the low level APIs for WebSocket. All APIs \ |
| 5 | are the synchronous functions." |
| 6 | HOMEPAGE = "https://github.com/websocket-client/websocket-client" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 7 | LICENSE = "LGPLv2.1" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c96ca6c1de8adc025adfada81d06fba5" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 10 | SRC_URI[sha256sum] = "63509b41d158ae5b7f67eb4ad20fecbb4eee99434e73e140354dc3ff8e09716f" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | PYPI_PACKAGE = "websocket_client" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 13 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | inherit pypi setuptools3 |
| 15 | |
| 16 | RDEPENDS_${PN} = "\ |
| 17 | ${PYTHON_PN}-six \ |
| 18 | " |