Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Line-oriented text editor" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/ed/" |
| 3 | |
| 4 | LICENSE = "GPLv3+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 6 | file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \ |
| 7 | file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | " |
| 9 | |
| 10 | SECTION = "base" |
| 11 | |
| 12 | CVE_PRODUCT = "gnu:ed" |
| 13 | |
| 14 | # LSB states that ed should be in /bin/ |
| 15 | bindir = "${base_bindir}" |
| 16 | |
| 17 | # Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/ |
| 18 | SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz" |
| 19 | UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/" |
| 20 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "71de39883c25b6fab44add80635382a10c9bf154515b94729f4a6529ddcc5e54" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 24 | |
| 25 | inherit texinfo |
| 26 | |
| 27 | do_configure() { |
| 28 | ${S}/configure |
| 29 | } |
| 30 | |
| 31 | do_install() { |
| 32 | oe_runmake 'DESTDIR=${D}' install |
| 33 | # Info dir listing isn't interesting at this point so remove it if it exists. |
| 34 | if [ -e "${D}${infodir}/dir" ]; then |
| 35 | rm -f ${D}${infodir}/dir |
| 36 | fi |
| 37 | } |