Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Plex86/Bochs LGPL VGABios" |
| 2 | HOMEPAGE = "http://www.nongnu.org/vgabios/" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | SECTION = "firmware" |
| 5 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | DEPENDS = "dev86-native biossums-native" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 7 | |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589" |
| 9 | |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 10 | SRC_URI = "http://savannah.gnu.org/download/vgabios/${BPN}-${PV}.tgz" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900" |
| 13 | SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865" |
| 14 | |
| 15 | PR = "r0" |
| 16 | |
| 17 | FILES_${PN} = "/usr/share/firmware/${PN}-${PV}*.bin" |
| 18 | FILES_${PN}-dbg = "/usr/share/firmware/${PN}-${PV}*.debug.bin" |
| 19 | |
| 20 | S = "${WORKDIR}/${PN}-${PV}" |
| 21 | |
| 22 | do_configure() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | # Override to use the native-built biossums tool: |
| 24 | sed 's,./biossums,biossums,' -i Makefile |
| 25 | sed 's,$(CC) -o biossums biossums.c,touch biossums,' -i Makefile |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}/usr/share/firmware |
| 30 | install -m 0644 VGABIOS-lgpl-latest.bin ${D}/usr/share/firmware/${PN}-${PV}.bin |
| 31 | install -m 0644 VGABIOS-lgpl-latest.cirrus.bin ${D}/usr/share/firmware/${PN}-${PV}.cirrus.bin |
| 32 | } |
| 33 | |