Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require pseudo.inc |
| 2 | |
| 3 | SRC_URI = " \ |
| 4 | http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \ |
| 5 | file://fallback-passwd \ |
| 6 | file://fallback-group \ |
| 7 | " |
| 8 | |
| 9 | SRC_URI[md5sum] = "2bd0a44eadd4713e90ad8c152eea77aa" |
| 10 | SRC_URI[sha256sum] = "e9fc3922f8feb97839b50d14eb1987afdc8f22cdcac93119323cccd5f8444652" |
| 11 | |
| 12 | PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback" |
| 13 | |
| 14 | do_install_append_class-native () { |
| 15 | install -d ${D}${sysconfdir} |
| 16 | # The fallback files should never be modified |
| 17 | install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd |
| 18 | install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group |
| 19 | } |