Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Filesystem and hardware benchmark and stress tool" |
| 2 | DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \ |
| 3 | stress/hardware verification. It has support for a number of I/O engines, \ |
| 4 | I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \ |
| 5 | and much more. It can work on block devices as well as files. fio accepts \ |
| 6 | job descriptions in a simple-to-understand text format. Several example job \ |
| 7 | files are included. fio displays all sorts of I/O performance information." |
| 8 | HOMEPAGE = "http://freecode.com/projects/fio" |
| 9 | SECTION = "console/tests" |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 12 | |
| 13 | DEPENDS = "libaio zlib" |
| 14 | RDEPENDS_${PN} = "python bash" |
| 15 | |
| 16 | PACKAGECONFIG_NUMA = "numa" |
| 17 | # ARM does not currently support NUMA |
| 18 | PACKAGECONFIG_NUMA_arm = "" |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame^] | 19 | PACKAGECONFIG_NUMA_armeb = "" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | |
| 21 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" |
| 22 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" |
| 23 | |
| 24 | # rev for v3.8 |
| 25 | SRCREV = "16500b5a0b03ee0142d592bb74a46943a223b06e" |
| 26 | SRC_URI = "git://git.kernel.dk/fio.git \ |
| 27 | file://0001-update-the-interpreter-paths.patch \ |
| 28 | " |
| 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
| 32 | # avoids build breaks when using no-static-libs.inc |
| 33 | DISABLE_STATIC = "" |
| 34 | |
| 35 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" |
| 36 | EXTRA_OECONF = "--disable-optimizations" |
| 37 | |
| 38 | do_configure() { |
| 39 | ./configure ${EXTRA_OECONF} |
| 40 | } |
| 41 | |
| 42 | do_install() { |
| 43 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} |
| 44 | install -d ${D}/${docdir}/${PN} |
| 45 | cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/ |
| 46 | } |