Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tool to produce a statistics based on a diff" |
| 2 | DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| 3 | the insertions, deletions, and modifications per-file. It is useful for \ |
| 4 | reviewing large, complex patch files." |
| 5 | HOMEPAGE = "http://invisible-island.net/diffstat/" |
| 6 | SECTION = "devel" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5" |
| 9 | |
| 10 | SRC_URI = "ftp://invisible-island.net/diffstat/diffstat-${PV}.tgz \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "ba889da4c06b547aa2d78fa96800ae6f" |
| 15 | SRC_URI[sha256sum] = "2032e418b43bae70d548e32da901ebc4ac12972381de1314bebde0b126fb0123" |
| 16 | |
| 17 | S = "${WORKDIR}/diffstat-${PV}" |
| 18 | |
| 19 | inherit autotools gettext ptest |
| 20 | |
| 21 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| 22 | |
| 23 | do_configure () { |
| 24 | if [ ! -e ${S}/acinclude.m4 ]; then |
| 25 | mv ${S}/aclocal.m4 ${S}/acinclude.m4 |
| 26 | fi |
| 27 | autotools_do_configure |
| 28 | } |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | cp -r ${S}/testing ${D}${PTEST_PATH} |
| 32 | } |