Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters" |
| 2 | DESCRIPTION = "hdparm is a Linux shell utility for viewing \ |
| 3 | and manipulating various IDE drive and driver parameters." |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "BSD" |
| 6 | LICENSE_wiper = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=910a8a42c962d238619c75fdb78bdb24 \ |
| 8 | file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \ |
| 9 | file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \ |
| 10 | file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09" |
| 11 | |
| 12 | |
| 13 | PACKAGES =+ "wiper" |
| 14 | |
| 15 | FILES_wiper = "${bindir}/wiper.sh" |
| 16 | |
| 17 | RDEPENDS_wiper = "bash gawk stat" |
| 18 | |
| 19 | SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz " |
| 20 | |
| 21 | SRC_URI[md5sum] = "213efdbe7471fad3408198918e164354" |
| 22 | SRC_URI[sha256sum] = "ce97b4a71cb04146f54cf6f69787e7f97ddfda9836dc803b459d3b3df3a4fbee" |
| 23 | |
| 24 | EXTRA_OEMAKE += 'STRIP="echo"' |
| 25 | |
| 26 | inherit update-alternatives |
| 27 | |
| 28 | ALTERNATIVE_${PN} = "hdparm" |
| 29 | ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm" |
| 30 | ALTERNATIVE_PRIORITY = "100" |
| 31 | |
| 32 | do_install () { |
| 33 | install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir} |
| 34 | oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install |
| 35 | cp ${S}/wiper/wiper.sh ${D}/${bindir} |
| 36 | } |