Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require xorg-driver-video.inc |
| 2 | |
| 3 | SUMMARY = "X.Org X server -- Intel integrated graphics chipsets driver" |
| 4 | |
| 5 | DESCRIPTION = "intel is an Xorg driver for Intel integrated graphics \ |
| 6 | chipsets. The driver supports depths 8, 15, 16 and 24. On some chipsets, \ |
| 7 | the driver supports hardware accelerated 3D via the Direct Rendering \ |
| 8 | Infrastructure (DRI)." |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e" |
| 11 | |
| 12 | SRC_URI += "file://disable-x11-dri3.patch \ |
| 13 | file://always_include_xorg_server.h.patch \ |
| 14 | file://sna-Protect-against-ABI-breakage-in-recent-versions-.patch \ |
| 15 | file://udev-fstat.patch \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "fa196a66e52c0c624fe5d350af7a5e7b" |
| 19 | SRC_URI[sha256sum] = "00b781eea055582820a123c47b62411bdf6aabf4f03dc0568faec55faf9667c9" |
| 20 | |
| 21 | DEPENDS += "virtual/libx11 drm libpciaccess pixman" |
| 22 | |
| 23 | PACKAGECONFIG ??= "xvmc sna udev ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri dri1 dri2', '', d)}" |
| 24 | |
| 25 | PACKAGECONFIG[dri] = "--enable-dri,--disable-dri" |
| 26 | PACKAGECONFIG[dri1] = "--enable-dri1,--disable-dri1,xf86driproto" |
| 27 | PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2,dri2proto" |
| 28 | PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3,dri3proto" |
| 29 | PACKAGECONFIG[sna] = "--enable-sna,--disable-sna" |
| 30 | PACKAGECONFIG[uxa] = "--enable-uxa,--disable-uxa" |
| 31 | PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev" |
| 32 | PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc xcb-util" |
| 33 | PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,libxinerama libxrandr libxdamage libxfixes libxcursor libxtst libxext libxrender" |
| 34 | |
| 35 | # --enable-kms-only option is required by ROOTLESS_X |
| 36 | EXTRA_OECONF += '${@base_conditional( "ROOTLESS_X", "1", " --enable-kms-only", "", d )}' |
| 37 | |
| 38 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' |
| 39 | |
| 40 | FILES_${PN} += "${datadir}/polkit-1" |