Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "http://www.gnome.org/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | SECTION = "x11/gnome/libs" |
| 9 | |
| 10 | DEPENDS = "glib-2.0 gnutls libxml2 sqlite3 intltool-native" |
| 11 | |
| 12 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable |
| 13 | # by default but let it be easily disabled. |
| 14 | PACKAGECONFIG ??= "gnome" |
| 15 | PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome" |
| 16 | |
| 17 | SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}" |
| 18 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
| 19 | |
| 20 | SRC_URI[md5sum] = "9a84d66e1b7ccd3bd340574b11eccc15" |
| 21 | SRC_URI[sha256sum] = "1e01365ac4af3817187ea847f9d3588c27eee01fc519a5a7cb212bb78b0f667b" |
| 22 | |
| 23 | S = "${WORKDIR}/libsoup-${PV}" |
| 24 | |
| 25 | inherit autotools gettext pkgconfig |
| 26 | |
| 27 | # glib-networking is needed for SSL, proxies, etc. |
| 28 | RRECOMMENDS_${PN} = "glib-networking" |