Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # Skip QA check for library symbolic links (core issue is a packaging problem within |
| 2 | # Singularity build / config: read up on the dev-so test for more info) |
| 3 | INSANE_SKIP_${PN} += "dev-so" |
| 4 | |
| 5 | RDEPENDS_${PN} += "glibc python3 ca-certificates openssl bash e2fsprogs-mke2fs" |
| 6 | # Singularity expects to find python3 under the name python, therefore both |
| 7 | # cannot be installed at the same time. |
| 8 | RCONFLICTS_${PN} = "python" |
| 9 | |
| 10 | LICENSE = "BSD" |
| 11 | LIC_FILES_CHKSUM = "file://COPYRIGHT.md;md5=be78c34e483dd7d8439358b1e024b294 \ |
| 12 | file://LICENSE-LBNL.md;md5=45a007b527e1a9507aa7fa869f8d7ede \ |
| 13 | file://LICENSE.md;md5=df4326b473db6424033f1d98a5645e30 \ |
| 14 | file://debian/copyright;md5=ed267cf386d9b75ab1f27f407e935b10" |
| 15 | |
| 16 | SRC_URI = "git://github.com/singularityware/singularity.git;protocol=https" |
| 17 | PV = "2.3.1+git${SRCPV}" |
| 18 | SRCREV = "e214d4ebf0a1274b1c63b095fd55ae61c7e92947" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit pythonnative autotools-brokensep |
| 23 | EXTRA_OECONF = "--prefix=/usr/local" |
| 24 | |
| 25 | pkg_postinst_${PN}() { |
| 26 | # Singularity requires "python" to resolve to "python3" within the commandline. |
| 27 | # This creates a symbolic link from python3 to python. A side-effect of this is |
| 28 | # that scripts which expect Python 2 may fail to run correctly. |
| 29 | ln -sr $D${bindir}/python3 $D${bindir}/python |
| 30 | |
| 31 | # python3 expects CA certificates to be installed in a different place to where |
| 32 | # they are actually installed. These lines link the two locations. |
| 33 | rm -r $D${libdir}/ssl-1.1/certs |
| 34 | ln -sr $D${sysconfdir}/ssl/certs $D${libdir}/ssl-1.1 |
| 35 | } |