Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require recipes-extended/chkconfig/chkconfig_1.3.58.bb |
| 2 | |
| 3 | SUMMARY = "${SUMMARY_chkconfig-alternatives}" |
| 4 | DESCRIPTION = "${DESCRIPTION_chkconfig-alternatives}" |
| 5 | DEPENDS = "" |
| 6 | PROVIDES += "virtual/update-alternatives-native" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 8 | |
| 9 | # The sysroot branch is 1.3.59 + some git commits from master + --sysroot |
| 10 | # support for alternatives. |
| 11 | SRC_URI = "git://github.com/kergoth/chkconfig;branch=sysroot" |
| 12 | S = "${WORKDIR}/git" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | UPSTREAM_CHECK_GITTAGREGEX = "chkconfig-(?P<pver>(\d+(\.\d+)+))" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
| 15 | SRCREV = "cd437ecbd8986c894442f8fce1e0061e20f04dee" |
| 16 | PV = "1.3.59+${SRCPV}" |
| 17 | |
| 18 | inherit native |
| 19 | |
| 20 | # We want our native recipes to build using the target paths rather than paths |
| 21 | # into the sysroot, as we may use them to construct the rootfs. As such, we |
| 22 | # only adjust the paths to match the metadata for the target, not native. |
| 23 | obey_variables () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' ${S}/alternatives.c |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | } |
| 26 | |
| 27 | do_compile () { |
| 28 | oe_runmake alternatives |
| 29 | } |
| 30 | |
| 31 | do_install () { |
| 32 | install -d ${D}${sysconfdir}/alternatives \ |
| 33 | ${D}${localstatedir}/lib/alternatives |
| 34 | |
| 35 | install -D -m 0755 alternatives ${D}${bindir}/alternatives |
| 36 | install -D -m 0644 alternatives.8 ${D}${mandir}/man8/alternatives.8 |
| 37 | |
| 38 | ln -s alternatives ${D}${bindir}/update-alternatives |
| 39 | ln -s alternatives.8 ${D}${mandir}/man8/update-alternatives.8 |
| 40 | } |
| 41 | |
| 42 | do_install_append_linuxstdbase() { |
| 43 | rm -rf ${D}${libdir}/lsb |
| 44 | } |