Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "The ssl.match_hostname() function from Python 3.4" |
| 2 | DESCRIPTION = "The Secure Sockets layer is only actually secure if you check the hostname in the \ |
| 3 | certificate returned by the server to which you are connecting, and verify that it matches to hostname \ |
| 4 | that you are trying to reach. But the matching logic, defined in RFC2818, can be a bit tricky to implement \ |
| 5 | on your own. So the ssl package in the Standard Library of Python 3.2 and greater now includes a \ |
| 6 | match_hostname() function for performing this check instead of requiring every application to \ |
| 7 | implement the check separately. This backport brings match_hostname() to users of earlier versions of Python" |
| 8 | |
| 9 | LICENSE = "GPLv2" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=95a5ee8fd779fbeca8b4cbca64433c87" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 12 | SRC_URI[md5sum] = "c03fc5e2c7b3da46b81acf5cbacfe1e6" |
| 13 | SRC_URI[sha256sum] = "502ad98707319f4a51fa2ca1c677bd659008d27ded9f6380c79e8932e38dcdf2" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | |
| 15 | PYPI_PACKAGE = "backports.ssl_match_hostname" |
| 16 | inherit pypi setuptools |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 17 | |
| 18 | RDEPENDS_${PN} += "${PYTHON_PN}-pkgutil" |