Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "A pure-Python SNMPv1/v2c/v3 library" |
| 2 | DESCRIPTION = "SNMP v1/v2c/v3 engine and apps written in pure-Python. \ |
| 3 | Supports Manager/Agent/Proxy roles, scriptable MIBs, asynchronous \ |
| 4 | operation (asyncio, twisted, asyncore) and multiple transports.\ |
| 5 | " |
| 6 | HOMEPAGE = "https://pypi.python.org/pypi/pysnmp" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=280606d9c18f200e03e0c247ac61475a" |
| 10 | |
| 11 | SRCNAME = "pysnmp" |
| 12 | |
| 13 | SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" |
| 14 | |
| 15 | SRC_URI[md5sum] = "387aaa23c168ccc0b59775cfdf519fc0" |
| 16 | SRC_URI[sha256sum] = "38253fe95cea33f352fb36e85f3c2874043401724300c4888df74835161169d2" |
| 17 | |
| 18 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 19 | |
| 20 | inherit setuptools |
| 21 | |
| 22 | RDEPENDS_${PN} += "python-pycrypto \ |
| 23 | python-pyasn1 \ |
| 24 | python-pysmi \ |
| 25 | " |