Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Templatized C++ Command Line Parser" |
| 2 | HOMEPAGE = "http://tclap.sourceforge.net/" |
| 3 | DESCRIPTION = "TCLAP is a small, flexible library that provides a simple interface \ |
| 4 | for defining and accessing command line arguments. It was intially inspired by the \ |
| 5 | user friendly CLAP libary. The difference is that this library is templatized, so \ |
| 6 | the argument class is type independent. Type independence avoids identical-except-for-type \ |
| 7 | objects, such as IntArg, FloatArg, and StringArg. While the library is not strictly \ |
| 8 | compliant with the GNU or POSIX standards, it is close. \ |
| 9 | " |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=5c64b2e8cc50917b2744a90950faa7cd" |
| 12 | |
| 13 | SRCREV = "799a8b1f99818e39fee19d0601030770af1221e1" |
| 14 | SRC_URI = "git://git.code.sf.net/p/tclap/code;branch=1.4 \ |
| 15 | file://0001-tclap-add-pkg-config-file.patch \ |
| 16 | " |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | inherit cmake |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | ALLOW_EMPTY:${PN} = "1" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |