Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | DEPENDS = "zlib-native jpeg-native libpng-native libxext-native libxft-native" |
| 4 | |
| 5 | inherit native |
| 6 | |
| 7 | EXTRA_OECMAKE += " \ |
| 8 | -DOPTION_BUILD_SHARED_LIBS=OFF \ |
| 9 | -DOPTION_USE_THREADS=OFF \ |
| 10 | -DOPTION_USE_XDBE=OFF \ |
| 11 | -DOPTION_USE_XFT=OFF \ |
| 12 | -DOPTION_BUILD_EXAMPLES=OFF \ |
| 13 | -DOPTION_USE_XINERAMA=OFF \ |
| 14 | -DOPTION_USE_XFIXES=OFF \ |
| 15 | -DOPTION_USE_XCURSOR=OFF \ |
| 16 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
| 18 | do_install_append() { |
| 19 | # make sure native fltk-config is not used accidentaly |
| 20 | rm -f ${D}${bindir}/fltk-config |
| 21 | } |