Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2012 - 2016 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "A modern implementation of DBM" |
| 5 | |
| 6 | DESCRIPTION = "Tokyo Cabinet is a library of routines for managing a database. \ |
| 7 | The database is a simple data file containing records, each is a pair of a key \ |
| 8 | and a value. Every key and value is serial bytes with variable length. \ |
| 9 | Both binary data and character string can be used as a key and a value. \ |
| 10 | There is neither concept of data tables nor data types. \ |
| 11 | Records are organized in hash table, B+ tree, or fixed-length array." |
| 12 | |
| 13 | HOMEPAGE = "http://fallabs.com/tokyocabinet/" |
| 14 | |
| 15 | LICENSE = "GPLv2" |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 17 | |
| 18 | SRC_URI = "http://fallabs.com/tokyocabinet/${BP}.tar.gz \ |
| 19 | file://remove-hard-coded-include-and-lib-paths.patch \ |
| 20 | " |
| 21 | |
| 22 | SRC_URI[md5sum] = "fd03df6965f8f56dd5b8518ca43b4f5e" |
| 23 | SRC_URI[sha256sum] = "a003f47c39a91e22d76bc4fe68b9b3de0f38851b160bbb1ca07a4f6441de1f90" |
| 24 | |
| 25 | DEPENDS = "bzip2 zlib" |
| 26 | |
| 27 | inherit autotools-brokensep |