Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI plugin for the Host I/O Mapping Protocol" |
| 2 | HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-flash" |
| 3 | PR = "r1" |
| 4 | PV = "0.1+git${SRCPV}" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ff331e820fda701d36a8f0efc98adc58" |
| 7 | |
| 8 | inherit autotools pkgconfig |
| 9 | inherit obmc-phosphor-ipmiprovider-symlink |
| 10 | |
| 11 | DEPENDS += "phosphor-ipmi-host" |
| 12 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | 46072e3 | 2020-04-06 09:13:05 -0500 | [diff] [blame] | 13 | DEPENDS += "sdbusplus" |
Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 14 | DEPENDS += "phosphor-logging" |
Patrick Williams | d6a0614 | 2020-06-09 21:00:08 -0500 | [diff] [blame] | 15 | DEPENDS += "phosphor-dbus-interfaces" |
Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 16 | |
| 17 | TARGET_CFLAGS += "-fpic" |
| 18 | |
| 19 | HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash" |
Andrew Geissler | ec32151 | 2021-04-27 23:50:20 +0000 | [diff] [blame] | 24 | SRCREV = "61e18614a64866026b5da05b11e51df2b8653bc4" |
Adriana Kobylak | e44af88 | 2018-09-21 10:09:36 -0500 | [diff] [blame] | 25 | |
| 26 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 27 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 28 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |