Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Note, we can probably remove the lzma option as it has be replaced with xz, |
| 2 | # and I don't think the kernel supports it any more. |
| 3 | SUMMARY = "Tools for manipulating SquashFS filesystems" |
| 4 | SECTION = "base" |
| 5 | LICENSE = "GPL-2 & PD" |
| 6 | LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \ |
| 8 | " |
| 9 | DEPENDS = "attr zlib xz lzo lz4" |
| 10 | |
| 11 | PV = "4.3+gitr${SRCPV}" |
| 12 | SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d" |
| 13 | SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \ |
| 14 | http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \ |
Patrick Williams | d7e9631 | 2015-09-22 08:09:05 -0500 | [diff] [blame] | 15 | file://0001-mksquashfs.c-get-inline-functions-work-with-C99.patch;striplevel=2 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | " |
| 17 | SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759" |
| 18 | SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e" |
| 19 | |
| 20 | S = "${WORKDIR}/git/squashfs-tools" |
| 21 | |
| 22 | # EXTRA_OEMAKE is typically: -e MAKEFLAGS= |
| 23 | # the -e causes problems as CFLAGS is modified in the Makefile, so |
| 24 | # we redefine EXTRA_OEMAKE here |
| 25 | EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1" |
| 26 | |
| 27 | do_compile() { |
| 28 | oe_runmake mksquashfs unsquashfs |
| 29 | } |
| 30 | do_install () { |
| 31 | install -d ${D}${sbindir} |
| 32 | install -m 0755 mksquashfs ${D}${sbindir}/ |
| 33 | install -m 0755 unsquashfs ${D}${sbindir}/ |
| 34 | } |
| 35 | |
| 36 | ARM_INSTRUCTION_SET = "arm" |
| 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |