Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "File classification tool" |
| 2 | DESCRIPTION = "File attempts to classify files depending \ |
| 3 | on their contents and prints a description if a match is found." |
| 4 | HOMEPAGE = "http://www.darwinsys.com/file/" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | # two clause BSD |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188" |
| 10 | |
| 11 | DEPENDS = "zlib file-replacement-native" |
| 12 | DEPENDS_class-native = "zlib-native" |
| 13 | |
| 14 | # Blacklist a bogus tag in upstream check |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)" |
| 16 | |
| 17 | SRC_URI = "git://github.com/file/file.git \ |
| 18 | file://debian-742262.patch \ |
| 19 | file://0001-Add-P-prompt-into-Usage-info.patch \ |
| 20 | " |
| 21 | |
| 22 | SRCREV = "d474e35513940dbca039b510b4de705b44f5bd9c" |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools |
| 26 | |
| 27 | EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 28 | EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 29 | |
| 30 | CFLAGS_append = " -std=c99" |
| 31 | |
| 32 | FILES_${PN} += "${datadir}/misc/*.mgc" |
| 33 | |
| 34 | do_install_append_class-native() { |
| 35 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 36 | --magic-file ${datadir}/misc/magic.mgc |
| 37 | } |
| 38 | |
| 39 | do_install_append_class-nativesdk() { |
| 40 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 41 | --magic-file ${datadir}/misc/magic.mgc |
| 42 | } |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |
| 45 | PROVIDES_append_class-native = " file-replacement-native" |
| 46 | # Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who |
| 47 | # depends on file-replacement-native. |
| 48 | bindir_append_class-native = "/file-native" |