Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Enchant Spell checker API Library" |
| 2 | SECTION = "libs" |
| 3 | HOMEPAGE = "https://abiword.github.io/enchant/" |
| 4 | LICENSE = "LGPLv2.1+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7" |
| 6 | |
| 7 | DEPENDS = "glib-2.0" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | |
| 11 | SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz" |
| 12 | SRC_URI[md5sum] = "c7b9d6a392ecb8758e499f783e8dc883" |
| 13 | SRC_URI[sha256sum] = "c7b5e2853f0dd0b1aafea2f9e071941affeec3a76df8e3f6d67a718c89293555" |
| 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases" |
| 16 | |
| 17 | S = "${WORKDIR}/enchant-${PV}" |
| 18 | |
| 19 | EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2" |
| 20 | |
| 21 | PACKAGECONFIG ??= "aspell" |
| 22 | PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell" |
| 23 | PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell" |
| 24 | |
| 25 | FILES_${PN} += " \ |
| 26 | ${datadir}/enchant-2 \ |
| 27 | ${libdir}/enchant-2 \ |
| 28 | " |
| 29 | FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a" |