Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "There are two major versions of the PCRE library. The \ |
| 2 | newest version is PCRE2, which is a re-working of the original PCRE \ |
| 3 | library to provide an entirely new API. The original, very widely \ |
| 4 | deployed PCRE library's API and feature are stable, future releases \ |
| 5 | will be for bugfixes only. All new future features will be to PCRE2, \ |
| 6 | not the original PCRE 8.x series." |
| 7 | SUMMARY = "Perl Compatible Regular Expressions version 2" |
| 8 | HOMEPAGE = "http://www.pcre.org" |
| 9 | SECTION = "devel" |
| 10 | LICENSE = "BSD-3-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://LICENCE;md5=b1588d3bb4cb0e1f5a597d908f8c5b37" |
| 12 | |
| 13 | SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2 \ |
| 14 | file://pcre-cross.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "d280b62ded13f9ccf2fac16ee5286366" |
| 18 | SRC_URI[sha256sum] = "74c473ffaba9e13db6951fd146e0143fe9887852ce73406a03277af1d9b798ca" |
| 19 | |
| 20 | CVE_PRODUCT = "pcre2" |
| 21 | |
| 22 | S = "${WORKDIR}/pcre2-${PV}" |
| 23 | |
| 24 | PROVIDES += "pcre2" |
| 25 | DEPENDS += "bzip2 zlib" |
| 26 | |
| 27 | BINCONFIG = "${bindir}/pcre2-config" |
| 28 | |
| 29 | inherit autotools binconfig-disabled |
| 30 | |
| 31 | EXTRA_OECONF = "\ |
| 32 | --enable-newline-is-lf \ |
| 33 | --enable-rebuild-chartables \ |
| 34 | --with-link-size=2 \ |
| 35 | --with-match-limit=10000000 \ |
| 36 | --enable-pcre2-16 \ |
| 37 | --enable-pcre2-32 \ |
| 38 | " |
| 39 | # Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to |
| 40 | # set CFLAGS_FOR_BUILD, required for the libpcre build. |
| 41 | BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}/src" |
| 42 | CFLAGS += "-D_REENTRANT" |
| 43 | CXXFLAGS_append_powerpc = " -lstdc++" |
| 44 | |
| 45 | export CCLD_FOR_BUILD ="${BUILD_CCLD}" |
| 46 | |
| 47 | PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc" |
| 48 | |
| 49 | SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes" |
| 50 | SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs" |
| 51 | SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions" |
| 52 | SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs" |
| 53 | |
| 54 | FILES_libpcre2-16 = "${libdir}/libpcre2-16.so.*" |
| 55 | FILES_libpcre2-32 = "${libdir}/libpcre2-32.so.*" |
| 56 | FILES_pcre2grep = "${bindir}/pcre2grep" |
| 57 | FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1" |
| 58 | FILES_pcre2test = "${bindir}/pcre2test" |
| 59 | FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1" |
| 60 | |
| 61 | BBCLASSEXTEND = "native nativesdk" |